Registerkarten

SimtippViewerServerKunstLL-BlogVideosVehikelAnleitungSansarARC

Sonntag, 17. Juli 2011

Probleme mit neustem SL-Viewer und Nvidia Geforce Treiber v275.33

Achtung! Zu diesem Thema gibt es neuere Informationen hier im Blog. Siehe unter:

Gestern hatte ich massive Probleme mit dem Grafikkartentreiber von Nvidia in Verbindung mit dem aktuellen Second Life Viewer. Ich hatte irgendwann einen Crash auf der RFL 2011 Veranstaltung und konnte dann nicht mehr einloggen. Folgender Fehler erschien immer am Ende des Einlogvorgangs, kurz bevor der Ladebalken ganz rechts angekommen war:

"The NVIDIA OpenGL driver lost connection with the display driver and is unable to continue. The application must close. Error code: 8."

Heute Morgen bin ich dann auf die Suche nach der Ursache gegangen. Offenbar gibt es einige SL-Nutzer mit einer Nvidia Grafikkarte, die die gleichen Probleme haben. Es wird vermutet, dass beim neusten GeForce Treiber eine Kollision zwischen einer internen Treiberfunktion und einer Textur-Ladefunktion des Viewers auftritt. Der Fehler entsteht nur beim GeForce-Treiber v275.33 und einem Viewer, dessen Codebasis 2.7.4 oder höher ist. Nicht betroffen scheinen die beiden älteren Treiber v270.61 und v266.58 zu sein. KirstenLee empfiehlt bei Problemen, generell auf die Version v266.58 zurückzugehen.

Nach weiterer Recherche habe ich jetzt aber auch einen Workaround gefunden, der Abhilfe schafft, ohne die nervige Prozedur einer Treiber-Neuinstallation. Und so gehts:

Grafikeinstellungen Viewer 2.8.0 mit Starlight Skin



  1. Nach Starten des Viewers bereits im Login-Bildschirm die Einstellungen öffnen
    • > Ich > Einstellungen > Grafik > General
  2. Zuerst 'Ambient Occlusion' und 'Lightning and Shadows' ausschalten
  3. Dann 'Hardware Skinning ausschalten
  4. Einstellung mit 'OK' verlassen und den Viewer nochmal neu starten
Nun sollte der Login wieder ohne den frustrierenden Absturz möglich sein. Wer möchte, kann dann inworld auch Hardware Skinning und Schatten wieder einschalten. Jedoch muss dann beim nächsten Login der o.a. Workaround wiederholt werden.

Ich hoffe, heute Nachmittag meine Runde auf der RFL 2011 Veranstaltung beenden zu können. Ein Bericht dazu stelle ich dann hier im Blog ein.

Kommentare:

  1. Selbiges Problem ist was mich angeht durchaus noch aktuell, Nvidia Treiber 280.26 und Kirstens S21 2.8.2.9

    "The NVIDIA OpenGL driver lost connection with the display driver and is unable to continue. The application must close. Error code: 8."

    Oben gezeigter Workaround funktioniert bei mir nicht, Generelle Grafiksettings auf Medium anstatt Ultra/High wie gewohnt , haben Abhilfe geschafft. Aber schön ist was anderes :(

    AntwortenLöschen
  2. Hallo,

    ja, der oben beschriebene Workaround funktioniert leider nicht immer zuverlässig. Hat er bei mir dann letztendlich auch nicht. Also habe ich mich die letzten 6 Wochen weiter damit befasst. Ich kann dir noch einen Workaround anbieten, der bei mir mit dem Kirstens funkioniert hat.

    Starte den Viewer und logge dich mit deinem Account ein. Sobald der Ladebalken zu sehen ist, minimierst du den Viewer in die Taskleiste von Windows. Nun wartest du mindestens so lange, wie es normalerweise dauert, bis sich dein Avatar und die inworld Umgebung aufgebaut hat. Das sind etwa 30 Sekunden bei mir gewesen. Wenn du dann den Viewer wieder aufklappst, sollte der Error 8 Fehler nicht auftreten. Und bei dieser Methode ist es egal, wie du deine Grafikeinstellungen gesetzt hast. Es geht also durchaus auch mit "Ultra".

    Das war mir aber auf die Dauer auch zu nervig. Der Error 8 Fehler ist nicht allein auf den Viewer zurückzuführen, sondern liegt an einer Umstellung der Nvidia Treiber auf OpenGL 3.0. Alle Programme, die irgendeine OpenGL 2.0 Funktion aufrufen, haben auch diesen Error 8 Fehler. Die einzige richtige Lösung, um das Problem derzeit dauerhaft zu umgehen, ist der Downgrade auf den Nvidia Treiber 260.99. Seit ich das gemacht habe, tritt der Fehler bei mir nicht mehr auf, da dies der letzte Treiber war, der OpenGL 2.0 voll unterstützt hat.

    Wichtig bei dem Downgrade ist, alle Reste des neueren Treibers vom Windows System zu entfernen, bevor man den 260.99 installiert. Ich habe den Treiber erst über die Uninstall-Funktion entfernt, dann das Programm "Drive Sweeper" benutzt, um Reste von Nvidia Dateien zu entfernen und zum Schluss noch den CCleaner gestartet, um auch verknüpfte Einträge aus der Registry zu entfernen. Dann habe ich Windows neu gestartet und den 260.99 installiert.

    Linden Lab ist gerade dabei, den Viewer auf reine OpenGL 3.0 Funktionen umzustellen. Solange sie damit noch nicht fertig sind, ist der Downgrade die beste Lösung. Aber für schnelle Abhilfe sollte auch das Minimieren des Viewers beim Login genügen.

    Gruß
    Maddy

    AntwortenLöschen
  3. Oh hey, vielen dank für diesen Vorschlag,Minimieren des Bildschirms ist mir auch aufgefallen, war mir aber nicht sicher ob dies nur Zufall war, was ich nicht wirklich für eine vernünftige Lösung halte. Ich hab heute den ganzen Tag gedowngraded wie irre, bin auch auf verschiede Registry Einträge gestoßen die dies beheben sollen, Fehlanzeige (im wahrsten Sinne des Wortes), ich glaube mittlerweile das das rein an den Treibern liegen muss, weil besagter Error Code 8 des öfteren auch in Photoshop auftreten soll und reportet wird. Treiber 260.99 , hat mein System nicht annehmen wollen (Win 7 64bit)

    AntwortenLöschen
  4. Okay, kleiner Edit bei meiner 260.99 Treiber Version handelte es sich um eine XP Version. ( wer lesen kann ist klar im Vorteil )

    Doch auch die Win7/Vista Version war mit meiner Grafikkarte nicht kompatibel (440GT).

    Wie dem auch sei, laut den Nvidia Foren, wo sich auch einige SL User beklagen gilt minimieren des Log In Fensters als einzige Lösung.

    Dann schauen wir mal fein Jira und Nvidia Foren und hoffen auf Besserung

    AntwortenLöschen
  5. Ich habe folgendes gefunden (im Nvidia Forum bezogen auf Error 8 & 4) , aber bisher noch nicht testen können:

    Try do the following:
    Nvidia Control Panel -> 3D Settings -> Manage 3D Settings -> Program Settings
    Select your program from the list or add it, if not in the list.
    In the "Power management mode" change it to "Prefer maximum performance".

    Ich werde das heute Abend mal durchprobieren, wäre natürlich toll wenn es helfen würde.

    AntwortenLöschen
  6. Das habe ich auch im Nvidia Forum gelesen. Allerdings habe ich keine Lust, jetzt wieder den neusten Treiber zu installieren, um das auszubrobieren. Klappt es nicht, müsste ich dann wieder zurück zum 260.99 Treiber.

    Sollte diese Einstellung bei dir funktionieren, kannst du es vielleicht ja hier noch kurz posten. Wenn der Fehler aber, wie von LL beschrieben, mit den Abfragen von OpenGL 2.0 Befehlen zusammenhängt, vermute ich mal, dass ein geändertes Powermanagement keine Abhilfe schafft.

    AntwortenLöschen